Reparo do display de um gerador de funções 33522A

Olá humano!

Após um longo e tenebroso inverno (de inverno não teve nada, somente um calor infernal e uma estiagem de fazer inveja ao Saara!), estou de volta.

Na ultima semana, adquiri um novo equipamento. Um gerador de funções da Agilent (hoje Keysight) modelo 33522A. Um gerador de funções e sinais arbitrários, com banda de 30MHz e dois canais. Uma coisa muito bonita de se ver (e usar).

Porem, como este equipamento ficou muito tempo parado (desde o final de 2011), e fora da sua embalagem original (sabe-se lá por onde andou, e a que pancadas foi submetido) quando fui compra-lo embora seu self-test tenha dado positivo, isto é, nenhum erro, seu display estava com uma coloração verde muito suspeita. Decidi no momento da compra que o fato do display estar com coloração diferente versus o desconto (grande) no valor junto ao fato de não haver erros no self-test era um ‘defeito’ aceitável.

Porem ao chegar em casa, no domingo, decidi que devido ao meu TOC (Transtorno Obsessivo Compulsivo) eu não conseguiria ficar muito tempo com o display da maneira que se encontrava, e decidi tentar repara-lo.

Como não estava pensando em fazer um post sobre isto, somente fiz uma foto do equipamento com o display esverdeado, que pode ser vista abaixo:

Display com 'defeito'
Figura 01: Display com ‘defeito’

Após baixar o manual do equipamento no site do fabricante (www.keysight.com.br), que alias é muito bom (como todo o material fornecido pela Agilent Keysight) e possui no final do mesmo um capitulo dedicado a reparo do mesmo. Neste capitulo existe um passo a passo para desmontar o equipamento da forma mais indicada (e vai por mim, é sempre bom ler esta parte). Após proceder a desmontagem do equipamento pude acessar o display. Para isso é necessário desmontar praticamente todas as partes do mesmo, somente ficando no lugar a placa mãe e a fonte. Uma coisa muito bacana é que todos os parafusos são Torx, e somente de três tamanhos diferentes, então é muito pratico de se trabalhar.

Após alguma dificuldade em uma parte do processo, consegui alcançar o painel frontal e chegar ao display. Devido a característica do problema apresentado, o display apresentava uma cor verde (limão) nos locais onde deveria exibir a cor preta, acreditei que o problema pudesse ser um mal contato (cabo solto, conector frouxo, solda fria, etc…) no bus de dados do display. Comecei então a checar as conexões da flex pcb do display, e ela somente fazia uma curva entre o display e a placa de circuito, e se conectava em um destes conectores smd típicos para placas de circuito flexíveis.

Desconectei a placa flexível, e retirei o display, que para minha surpresa é fabricado no Japão (pela NEC), figura 02, coisa rara hoje em dia (rsrs).

Display LCD
Figura 02: Display LCD

A qualidade do display é indescritível, acabamento lindo, inox polido, sem rebarbas, extremamente bem fabricado. Voltando ao problema, após reconectar e remontar o equipamento, o display deixou de funcionar de vez, ficando preto em definitivo.

Após alguns ciclos de montagem e desmontagem do gerador, decidi usar a ferramenta mais avançada que possuo para casos de mal contato, figura 03:

Lápis borracha, ferramenta indispensavel
Figura 03: Lápis borracha, ferramenta indispensável

Desculpem não ter tirado fotos do processo, mas esta imagem (figura 04) do manual deve ser útil:

Conector do display.
Figura 04: Conector do display.

A seta indicando ‘Ribbon Cable‘ mostra onde esta o conector e a placa de circuito impresso flexível (PCF). Foi nesta placa flexível que eu passei a borracha para limpar os contatos, e reconectei a placa no conector. Aproveitando que eu já estava com a borracha em mãos e com o equipamento todo desmontado, eu aproveitei para passar a borracha na placa ‘do processador’ que vai conectada ao painel frontal, pela parte de baixo do equipamento, figura 05.

Outra placa onde usei a borracha.
Figura 05: Outra placa onde usei a borracha.

Após esta ‘limpeza’ nos contatos, montei novamente o equipamento e liguei. Finalmente consegui um display funcionando novamente, e mais, agora estava funcionando com as cores corretas.

Porem como nem tudo pode ser tão simples, o gerador indicava uma mensagem de erro. Dizendo que o clock do RTC estava ruim, ou erro 601. Tudo indicava que era problema na bateria. Mas em algum ponto do manual é dito que quando desconectamos as placas por algum tempo, o RTC (Real Time Clock) pode perder a configuração. Então eu reconfigurei a data e hora do gerador, e reiniciei o mesmo. Pronto, agora estava tudo funcionando perfeitamente. O display voltou a funcionar e a mensagem de erro havia sumido, figura 06.

Display sem problemas
Figura 06: Display sem problemas

Fica a dica para quem tem algum problema parecido (erro 601 ou display esverdeado, que pode também acontecer com vermelho ou azul, as cores do sistema RGB, Red Green Blue, que é utilizado nestes displays). Aliás, este problema em displays pode acontecer em qualquer equipamento ou monitor, e geralmente é algum tipo de mal contato. Fica a dica.

Algumas fotos do gerador:

Agilent 33522A
Agilent 33522A

 

 

 

 

 

Agilent 33522A
Agilent 33522A

 

 

 

 

 

Até a próxima!

Deixe uma resposta