Calibração multímetro 34401A

Olá humano!

Neste ultimo final de semana fui com um amigo (também quase-engenheiro), na casa de um outro amigo, que recentemente adquiriu um padrão de tensão da Data Precision, que foi comparado com um multímetro calibrado e estes ‘bateram’. Levei então o meu multímetro de bancada para verificar sua calibração.

Figura 01: Tensão de 12V
Figura 01: Tensão de 12V

Continue lendo “Calibração multímetro 34401A”

Reparo do display de um gerador de funções 33522A

Olá humano!

Após um longo e tenebroso inverno (de inverno não teve nada, somente um calor infernal e uma estiagem de fazer inveja ao Saara!), estou de volta.

Na ultima semana, adquiri um novo equipamento. Um gerador de funções da Agilent (hoje Keysight) modelo 33522A. Um gerador de funções e sinais arbitrários, com banda de 30MHz e dois canais. Uma coisa muito bonita de se ver (e usar).

Porem, como este equipamento ficou muito tempo parado (desde o final de 2011), e fora da sua embalagem original (sabe-se lá por onde andou, e a que pancadas foi submetido) quando fui compra-lo embora seu self-test tenha dado positivo, isto é, nenhum erro, seu display estava com uma coloração verde muito suspeita. Decidi no momento da compra que o fato do display estar com coloração diferente versus o desconto (grande) no valor junto ao fato de não haver erros no self-test era um ‘defeito’ aceitável.

Porem ao chegar em casa, no domingo, decidi que devido ao meu TOC (Transtorno Obsessivo Compulsivo) eu não conseguiria ficar muito tempo com o display da maneira que se encontrava, e decidi tentar repara-lo.

Como não estava pensando em fazer um post sobre isto, somente fiz uma foto do equipamento com o display esverdeado, que pode ser vista abaixo:

Display com 'defeito'
Figura 01: Display com ‘defeito’

Continue lendo “Reparo do display de um gerador de funções 33522A”

GPIB no Delphi (placa da National)

Olá humano!

Demora em escrever à parte (ainda estou no final da graduação, peguem leve comigo! rs), vou colocar um pequeno passo, porém pode ser de grande valia para mais alguém, em sobre a comunicação GPIB em Delphi (ou Kylix, ou Lazarus).

Bom para quem não conhece o GPIB (General Purpose Interface Bus), ou ainda HP-IB ou IEEE-488, foi desenvolvido pela Hewlett-Packard (HP) na década de 60, por isso já foi conhecido (naquela época) por HPIB (Hewlett-Packard Instrument Bus), para a interface com seus instrumentos de medição. Alguns anos depois, a HP licenciou este protocolo que foi bastante usado por outros fabricantes de equipamentos de teste e medição. Posteriormente, em 1975, o IEEE (Institute of Electrical and Electronics Engineers) padronizou este barramento.

Cabo GPIB
Figura 01: Cabo GPIB

Continue lendo “GPIB no Delphi (placa da National)”

Dica para osciloscopio (sinal com ruido)

Olá humano!

Este será um post mais curto, mas nem por isso deixa de ser interessante.

Para aqueles que ainda não estão acostumados a utilizar um osciloscópio (principalmente os digitais), ou que estão começando agora, vou mostrar como a função média pode ser muito útil.

A função média nos apresenta na tela do osciloscópio uma média do sinal amostrado, logo ela leva mais tempo para atualizar a tela. Mas qual o ganho em olharmos para a média de um sinal ao longo do tempo? Simples, quando estamos trabalhando em um ambiente onde temos muita interferência, ou ruido (elétrico), o sinal que queremos ver fica deteriorado, e em alguns casos fica impossível realizarmos algumas medidas, ou o erro fica muito grande. É ai que entra o recurso de média do sinal.

Abaixo podemos verificar o mesmo sinal capturado em um ambiente com muito ruido elétrico, que atrapalhava a medição correta do sinal. Na figura 01 temos o sinal amostrado normalmente, e na figura 02 o ‘mesmo’ (o sinal é proveniente do mesmo equipamento, sob as mesmas condições do primeiro, mas num momento de tempo diferente) sinal exibido com o uso da função média do osciloscópio.

Sinal com ruido.
Figura 01: Sinal com ruido.

Após o uso da função de média obtemos o seguinte:

Sinal com uso da função de média
Figura 02: Sinal com uso da função de média

Como podemos verificar nas imagens, temos uma medida de pico-a-pico de 113mV antes da média e 78.9mV após a media, e frequência de 7.4516Hz contra 7.500Hz.

No caso utilizamos 16 medias, mas este osciloscópio permite que selecionemos entre 8, 16, 32 e 64 medições. Neste caso o osciloscópio realiza 16 medições, faz a media destas medições e apresenta na tela o resultado. Mas porque isto ‘limpa’ o ruido?

Uma analise mais matemática nos mostra que enquanto o sinal que queremos é repetitivo (e este recurso só funciona nestes casos), o ruido, ou interferência, não é. Traduzindo de maneira mais praticas, o que temos é o seguinte, em sinais repetitivos, quanto mais tempo calcularmos médias mais próximos chegamos do sinal original, pois a interferência não acontece de maneira repetitiva, ora ela aparece em um momento, ora em outro. Por exemplo, caso exista uma interferência num pico da senoide no primeiro ciclo, no segundo ciclo ela aparece na passagem pelo zero. Ou no primeiro ciclo ela acontece de maneira positiva (um sinal positivo, que aumenta o sinal original) e no segundo (ou qualquer outro) ciclo, ela acontece de maneira negativa (diminuindo, ou atenuando, o sinal original).

Porem como tudo na engenharia, nem sempre isso funciona ou é indicado. Como por exemplo, não funciona em sinais não repetitivos, ou em casos de disparo único (single shot), uma vez que precisamos ‘ver’ vários ciclos do sinal para calcularmos a sua média.

Usando a media, a atualização da tela fica mais lenta (quanto maior o numero de amostras, mais lenta a atualização). E com isso também perdemos a capacidade de verificar sinais esporádicos. Portanto sempre precisamos ponderar quando é útil utilizarmos este recurso, e quando este recurso limita nossa percepção.

Bom, acho que consegui mostrar a utilidade e limites deste recurso. Qualquer duvida se manifeste nos comentários abaixo.

Caso seja útil esta informação, o osciloscópio utilizado foi o DSOX-2002 da Agilent (2 canais, 70MHz)

Até a próxima!

Calibração Fonte Agilent E3640A

Olá humano!

Como já disse anteriormente eu adquiri uma fonte (E3640A) usada. Alias bem usada. Porem em condições muito boas, tirando varias marcas de cola (adesivos, provavelmente calibração ou patrimônio) na frente do instrumento. Uma vez em minha posse, cadastrei seu numero serial em minha conta no site da Agilent e com isso pude verificar a idade desta fonte. Ela chegou até mim dez anos depois de sair da fabrica (foi produzida em 2004), e devido a condição da mesma, deve ter sido intensamente utilizada. Nada mais justo do que imaginar que se encontraria descalibrada.

Verificando a tensão nos bornes de saída, verifiquei que de fato existia um erro razoável. Para facilitar a visualização, vou colocar um gráfico mostrando a curva de saída, com valores medidos em meu multímetro de bancada:

Erro Inicial
Erro inicial

Observamos no gráfico que quanto maior o valor de saida, maior o erro. Sendo que o maior erro (absoluto) foi encontrado quando coloquei a fonte em 0.01V e obtive um erro de 0.0057 (erro pequeno), e o menor erro (valor absoluto) obtive com a fonte em 20.30V quando o valor do erro foi de -0.2612V. Estes valores podem ser verificados no arquivo pdf disponivel aqui.

Como sei que esta fonte deve mostrar no display o valor exato (ou bastante próximo disso) da sua saída, uma vez que possuo também o modelo E3649A, decidi que eu deveria calibra-la, ou algo próximo disto, aqui em casa. Calibrar neste caso seria fazer com o que tenho de equipamento aqui em casa. Neste caso, usei meu multímetro 34401A, de 6,5 dígitos.

Este multímetro foi ‘recém’ calibrado (2010) e confere com meu U1273A (até onde este ultimo é capaz de mostrar), recém adquirido e ainda dentro da calibração de fabrica. Para calibrar a fonte, deixei ambos (multímetro e fonte) ligados por um período de três horas, como warm-up e procedi então como descrito no manual (manual da fonte).

Durante a calibração, deixei o multímetro de mão, conectado em paralelo com o 34401A como um ‘teste de sanidade’. Abaixo coloco uma foto do set-up que utilizei:

Foto do set-up utilizado para a calibração.
Foto do set-up utilizado para a calibração.

Quanto a calibração da escala de corrente, utilizei dois resistores de 3W (0.22Ω) em paralelo, para fazer um shunt de aproximadamente 0.1Ω. Pois não tenho nenhum shunt próprio, como por exemplo o recomendado para medições de corrente do próprio 34401A, um shunt que se encaixa no painel do instrumento, e possui um valor calibrado (shunt da Agilent).

Mas da maneira que fiz, obtive um resultado satisfatório. Talvez num futuro, eu faça, ou consiga emprestado (algum voluntario?) um shunt melhor, e refaça a calibração.

Após a calibração, obtive o seguinte resultado:

Erro Final.
Erro Final.

A primeira vista este gráfico pode parecer pior do que o primeiro, mas quando o colocamos na mesma escala do primeiro, obtemos a seguinte imagem:

Erro Final na mesma escala que o Inicial.
Erro Final na mesma escala que o Inicial.

Após a calibração, obtive os seguintes erros absolutos: -0.0021V para a fonte em 0.30V e -0.0043V para a fonte em 20.40V. A variação do erro tambem ficou menor após a calibração, como era de se esperar, diminuiu de 0.2669V para 0.0022V no range total da fonte (20.6V). Uma diminuição maior que 120 vezes.

Eu sei que esta calibração não equivale a uma realizada em um laboratório de calibração, mas para meu uso pessoal, é mais do que o suficiente.

Para terminar vou dizer que fiquei contente com o resultado, a fonte ‘pegou’ a calibração caseira, agora os valores do display correspondem a saída e descobri que a calibração dessa (talvez de toda esta linha) fonte não é um bicho de sete cabeças.

PS: Escrevendo este post fiquei em duvida se o correto era escrever setup ou set-up, e pesquisando encontrei este link, que achei bastante útil e por isso resolvi coloca-lo aqui: Setup, Set-up ou Set up.